lkml.org 
[lkml]   [2010]   [Sep]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: commit 7b2bfdb broke sound card detection on my Lenovo T400s
At Tue, 7 Sep 2010 00:45:48 +0200,
Jens Taprogge wrote:
>
> On Mon, Sep 06, 2010 at 07:04:21PM +0200, Frank Becker wrote:
> > Hi,
> >
> > Please always CC me since I'm not subscribed to the mailing lists.
> >
> > I have a problem since commit id 7b2bfdb (about 2.6.35-rc2) up to the
> > latest HEAD on my Lenovo T400s laptop. Just found out while testing Ubuntu
> > 10.10.
> >
> > Problem is: Headphones don't work any more, internal Microphone doesn't
> > work any more. However, if I load snd-hda-intel with the option
> > model=ideapad the mic and the headphones work perfectly well again. For now
> > that is an acceptable work around. However, before the aforementioned
> > commit I didn't have to provide any module parameters.
> >
> > Before rev 7b2bfdb I had:
> > └[a8@t4]-~→find /proc/asound/card* -type f | grep codec | xargs grep \
> > "^Codec\|^Vendor Id\|^Subsystem Id\|^Revision Id"
> > Codec: Conexant ID 5069
> > Vendor Id: 0x14f15069
> > Subsystem Id: 0x17aa2132
> > Revision Id: 0x100300
> >
> > Starting with rev 7b2bfdb I get:
> > └[a8@t4]-~→find /proc/asound/card* -type f | grep codec | xargs grep \
> > "^Codec\|^Vendor Id\|^Subsystem Id\|^Revision Id"
> > Codec: Conexant CX20585
> > Vendor Id: 0x14f15069
> > Subsystem Id: 0x17aa2132
> > Revision Id: 0x100300
> >
> > BTW, all the bisecting is done out of the linus.git tree.
> >
> > Thank you for looking into that. I'm happy to provide more information or test
> > patches.
> >
> > Thanks,
> >
> > Frank
> >
> >
> > --
> > Frank Becker <fb@alien8.de> (jabber|mail) | http://twitter.com/41i3n8
> > GnuPG: 0xADC29ECD | F01B 5E9C 1D09 981B 5B40 50D3 C80F 7459 ADC2 9ECD
> > SILC-Net: a8 | Home: http://www.alien8.de | <<</>> http://www.c3d2.de
> > "> Freedom is just chaos, with better lighting. <" Alan Dean Foster
>
> Hello Frank,
>
> apparently the devices are wired differently on the T410s (which works
> here) and the T400s.
>
> Have you tried playing with the mixers? There might be additional ones
> present after the patch.
>
> Also when you say things work perfectly when specifying "model=ideapad",
> does that include automatic switching between internal and external
> microphones? Have you attached your T410 to a docking station?

Also, it'd be helpful if alsa-info.sh output is given.
Jens, Frank, could you guys run it with --no-upload option and attach
the output for comparison?


thanks,

Takashi
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2010-09-07 08:05    [W:0.039 / U:0.964 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site