lkml.org 
[lkml]   [2010]   [Sep]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH -v2 6/7] x86, NMI, Add support to notify hardware error with unknown NMI
On Tue, Sep 28, 2010 at 08:36:12AM +0800, Huang Ying wrote:
> > I tend to agree with Robert here. I don't know if there were any 'rules'
> > to which handlers get directly called versus ones that go through the
> > die_chain, so I was originally going to let it go. But if they aren't
> > any, it does look cleaner to have everything in die_chains.
>
> Personally, I think directly call has better readability than

I am confused what type of readability you are looking for? Can we create
a sysfs entry to give you that info?

> notifier_chain in general. Notifier_chain is for:
>
> - Call functions in module.
> - Need to enable/disable (via register/unregister) at run time.
> - Call functions from low layer to high layer.
>
> Otherwise, notifier_chain should be avoid if possible. So I think it is
> better to keep direct call as much as possible.

But the problem is you have to export all this platform specific stuff to
traps.c and surround the code with #ifdef's, which start to look ugly.

Is there any reason why traps.c should know about MCA/HEST/<other hardware
errors>? Shouldn't it be abstracted away?

Honestly, I would be interested in creating a southbridge driver and
moving the port 0x61 code there and keeping the default_do_nmi() function
stupidly simple (just a call to the die_chain and the
unknown_nmi_error()).

Just my two cents.

Cheers,
Don


\
 
 \ /
  Last update: 2010-09-28 17:35    [W:0.244 / U:0.460 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site