lkml.org 
[lkml]   [2010]   [Sep]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [BUG] object: is not initialized, yet kobject_put() is being called
On Mon, 20 Sep 2010, Heinz Diehl wrote:

> On 12.08.2010, Heinz Diehl wrote:
>
> > > >>Could please those of you, who are able to reproduce the problem, verify
> > > >>whether the patch below (completely untested) makes everything behave
> > > >>again? Thanks.
>
> > > >Yes, everything behaves again. Thanks Jiri.
>
> > > Seconded. Works good. Thanks for your support Jiri.
>
> > Thirded! This fixes the warning here.
>
> Unfortunately, I have to take up this problem a second time.
> I considered the issue fixed, and in fact it was using Jiris patch.
>
> However, the same problem came back while testing 2.6.36-rc4 and the
> following -git's. /var/log/warn shows the same warning as mentioned in
> the first mail in this thread:
>
> Sep 20 08:18:42 liesel apcupsd[5436]: apcupsd FATAL ERROR in linux-usb.c at line 609
> Cannot find UPS device -- For a link to detailed USB trouble
> shooting information, please see <http://www.apcupsd.com/support.html>.
> Sep 20 08:18:42 liesel apcupsd[5436]: apcupsd error shutdown completed
>
> No additional oops this time, only the warning, and my UPS is no longer
> working.
>
> Jiris patch obviously didn't made it into 2.6.36-rc4, and it doesn't
> apply nay longer either.

No, you're wrong. The patch _is_ in 2.6.36-rc4, and that's the reason
why it doesn't apply any longer.

The error you see must have a different cause. Have you read this
thread?

http://marc.info/?t=128494644600005&r=1&w=2
Alan Stern



\
 
 \ /
  Last update: 2010-09-20 21:01    [from the cache]
©2003-2011 Jasper Spaans