lkml.org 
[lkml]   [2010]   [Sep]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 10/14] scsi: osd: fix device_register() error handling
On Sun, Sep 19, 2010 at 16:26 +0200, Dan Carpenter wrote:
> On Sun, Sep 19, 2010 at 04:55:07PM +0400, Vasiliy Kulikov wrote:
> > If device_register() fails then call put_device().
> > See comment to device_register.
> >
> > Signed-off-by: Vasiliy Kulikov <segooon@gmail.com>
> > ---
...
>
> Hm... So if device_register() fails then we should always call
> device_put()? It seems like a lot of existing code does that but I
> hadn't realized until now that that is how it works.

Yes, almost ALL code using device_register() is buggy :-(

> Why can't the device_put() just be added inside the device_register() so
> the unwinding works automatically?

Because some code already calls device_put(). Also it is documented like
not putting the device. However, I'm in doubt why it is written this way.

> Also if someone add some more stuff to the end of this function, will
> the device_unregister() followed by a device_put() cause problems if we
> unwind like this?

Yes, device_register() gets one reference, you should put in in both cases -
when device_register() failed and when it succeeded, but only one time.
device_unregister() puts it, so it is "double putting".

> +err_free_something:
> + kfree(foo);
> + device_unregister(&oud->class_dev);
> > +err_put_device:
> > + put_device(&oud->class_dev);
> > err_put_cdev:
> > cdev_del(&oud->cdev);
> > err_put_disk:
>
> If that's the case then the put_device() should be called infront of the
> goto.

As it is the last call that may fail, it is redundant. Or you mean for future,
if someone adds more code after device_register()?


Thanks,
--
Vasiliy


\
 
 \ /
  Last update: 2010-09-19 16:43    [W:0.056 / U:0.620 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site