lkml.org 
[lkml]   [2010]   [Sep]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH][-mm] memcg : memory cgroup cpu hotplug support update.
* KAMEZAWA Hiroyuki <kamezawa.hiroyu@jp.fujitsu.com> [2010-09-16 16:17:27]:

> On Thu, 16 Sep 2010 15:22:04 +0900
> KAMEZAWA Hiroyuki <kamezawa.hiroyu@jp.fujitsu.com> wrote:
>
> > This naming is from mem_cgroup_walk_tree(). Now we have
> >
> > mem_cgroup_walk_tree();
> > mem_cgroup_walk_all();
> >
> > Rename both ? But it should be in separated patch.
> >
>
> Considering a bit ...but..
>
> #define for_each_mem_cgroup(mem) \
> for (mem = mem_cgroup_get_first(); \
> mem; \
> mem = mem_cgroup_get_next(mem);) \
>
> seems to need some helper functions. I'll consider about this clean up
> but it requires some amount of patch because css_get()/css_put()/rcu...etc..
> are problematic.
>

Why does this need to be a macro (I know we use this for lists and
other places), assuming for now we don't use the iterator pattern, we
can rename mem_cgroup_walk_all() to for_each_mem_cgroup().

--
Three Cheers,
Balbir


\
 
 \ /
  Last update: 2010-09-17 08:37    [W:0.277 / U:0.048 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site