lkml.org 
[lkml]   [2010]   [Jul]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: [PATCH 12/25] char: Convert pci_table entries to PCI_VDEVICE (if PCI_ANY_ID is used)
    On Thu, Jul 15, 2010 at 08:52:37PM +0200, Peter Huewe wrote:
    > From: Peter Huewe <peterhuewe@gmx.de>
    >
    > This patch converts pci_table entries, where .subvendor=PCI_ANY_ID and
    > .subdevice=PCI_ANY_ID, .class=0 and .class_mask=0, to use the
    > PCI_VDEVICE macro, and thus improves readability.
    >
    > Signed-off-by: Peter Huewe <peterhuewe@gmx.de>
    > ---
    > drivers/char/epca.c | 8 ++++----
    > 1 files changed, 4 insertions(+), 4 deletions(-)
    >
    > diff --git a/drivers/char/epca.c b/drivers/char/epca.c
    > index d9df46a..5dafcdb 100644
    > --- a/drivers/char/epca.c
    > +++ b/drivers/char/epca.c
    > @@ -2762,10 +2762,10 @@ err_out:
    >
    >
    > static struct pci_device_id epca_pci_tbl[] = {
    > - { PCI_VENDOR_DIGI, PCI_DEVICE_XR, PCI_ANY_ID, PCI_ANY_ID, 0, 0, brd_xr },
    > - { PCI_VENDOR_DIGI, PCI_DEVICE_XEM, PCI_ANY_ID, PCI_ANY_ID, 0, 0, brd_xem },
    > - { PCI_VENDOR_DIGI, PCI_DEVICE_CX, PCI_ANY_ID, PCI_ANY_ID, 0, 0, brd_cx },
    > - { PCI_VENDOR_DIGI, PCI_DEVICE_XRJ, PCI_ANY_ID, PCI_ANY_ID, 0, 0, brd_xrj },
    > + { PCI_VDEVICE(DIGI, PCI_DEVICE_XR), brd_xr },
    > + { PCI_VDEVICE(DIGI, PCI_DEVICE_XEM), brd_xem },
    > + { PCI_VDEVICE(DIGI, PCI_DEVICE_CX), brd_cx },
    > + { PCI_VDEVICE(DIGI, PCI_DEVICE_XRJ), brd_xrj },

    The main reason I hate this macro, is that it now makes it almost
    impossible to grep for any users of the PCI_VENDOR_DIGI pci vendor id.
    I much prefer the PCI_DEVICE() macro instead, and as such, I'm not
    willing to take any of these patches, sorry.

    greg k-h


    \
     
     \ /
      Last update: 2010-07-15 22:53    [W:6.412 / U:0.048 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site