lkml.org 
[lkml]   [2010]   [Jul]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] x86: fix x2apic preenabled system with kexec
On 07/15/2010 01:10 PM, Yinghai Lu wrote:
> On 07/15/2010 11:16 AM, Suresh Siddha wrote:
>> On Thu, 2010-07-15 at 00:00 -0700, Yinghai Lu wrote:
>>
>>> BTW: is there any x2apic preenabled system with apicid of boot cpu > 255?
>>
>> I am not sure. There might be one. Is there any bug which can't handle
>> this condition?
>
> We merged apic_ops into struct apic a while ago.
>
> so even for system with x2apic preenabled by BIOS, x2apic_cluster/phys is set to apic until smp_pare_cpus()::default_setup_apic_routing() after enable_IR_x2apic.
>
> that means the boot cpu x2apic is accessed via memmap instead msr based way at that point.
>
> not sure if the Boot apic id is bigger than 255. read_apic() for apic id could be wrong. ( in early_acpi_boot_init, acpi_boot_init, init_apic_mappings)
>
> looks like we need to re-read boot_cpu_physical_apicid
> or we could assign x2apic_cluster/phys in check_x2apic(), and later if intr_remapping can not be enabed, we can revert back to phys_flat or flat?
>

never mind,

early_acpi_boot_init::acpi_parse_madt::default_acpi_madt_oem_check() will handle the case.
it will set the apic to apic_x2apic_... accordingly if x2apic is preenabled.

Thanks

Yinghai


\
 
 \ /
  Last update: 2010-07-15 22:47    [from the cache]
©2003-2011 Jasper Spaans