[lkml]   [2010]   [Jul]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: Raise initial congestion window size / speedup slow start?
    From: Hagen Paul Pfeifer <>
    Date: Wed, 14 Jul 2010 22:39:19 +0200

    > * Rick Jones | 2010-07-14 13:17:24 [-0700]:
    >>There is an effort under way, lead by some folks at Google and
    >>including some others, to get the RFC's enhanced in support of the
    >>concept of larger initial congestion windows. Some of the discussion
    >>may be in the "tcpm" mailing list (assuming I've not gotten my
    >>mailing lists confused). There may be some previous discussion of
    >>that work in the netdev archives as well.
    > tcpm is the right mailing list but there is currently no effort to develop
    > this topic. Why? Because is not a standardization issue, rather it is a
    > technical issue. You cannot rise the initial CWND and expect a fair behavior.
    > This was discussed several times and is documented in several documents and
    > RFCs.
    > RFC 5681 Section 3.1. Google employees should start with Section 3. This topic
    > pop's of every two months in netdev and until now I _never_ read a
    > consolidated contribution.
    > Partial local issues can already be "fixed" via route specific ip options -
    > see initcwnd.

    Although section 3 of RFC 5681 is a great text, it does not say at all
    that increasing the initial CWND would lead to fairness issues.

    To be honest, I think google's proposal holds a lot of weight. If
    over time link sizes and speeds are increasing (they are) then nudging
    the initial CWND every so often is a legitimate proposal. Were
    someone to claim that utilization is lower than it could be because of
    the currenttly specified initial CWND, I would have no problem
    believing them.

    And I'm happy to make Linux use an increased value once it has
    traction in the standardization community.

    But for all we know this side discussion about initial CWND settings
    could have nothing to do with the issue being reported at the start of
    this thread. :-)

     \ /
      Last update: 2010-07-14 23:57    [W:0.031 / U:165.164 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site