[lkml]   [2010]   [Jun]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 03/28] rename anon_vma_lock to vma_lock_anon_vma
On Mon, Jun 07, 2010 at 01:06:57PM +0200, Peter Zijlstra wrote:
> From: Rik van Riel <>
> Rename anon_vma_lock to vma_lock_anon_vma. This matches the
> naming style used in page_lock_anon_vma and will come in really
> handy further down in this patch series.
> Signed-off-by: Rik van Riel <>
> Acked-by: Mel Gorman <>
> Acked-by: KAMEZAWA Hiroyuki <>
> Signed-off-by: Peter Zijlstra <>
> LKML-Reference: <>

One rename was missed I think. With this patch applied, I get

mm/mmap.c: In function ‘expand_downwards’:
mm/mmap.c:1786: error: implicit declaration of function ‘anon_vma_unlock’
make[1]: *** [mm/mmap.o] Error 1
make[1]: *** Waiting for unfinished jobs....
make: *** [mm] Error 2

Mel Gorman
Part-time Phd Student Linux Technology Center
University of Limerick IBM Dublin Software Lab
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2010-06-09 13:01    [from the cache]
©2003-2014 Jasper Spaans. hosted at Digital Ocean