lkml.org 
[lkml]   [2010]   [Jun]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRE: [Regression] mptsas won't boot with 2.6.35-rc2


> -----Original Message-----
> From: john stultz [mailto:johnstul@us.ibm.com]
> Sent: Tuesday, June 08, 2010 9:07 AM
> To: lkml
> Cc: Chris McDermott; James.Bottomley@suse.de; Desai, Kashyap
> Subject: [Regression] mptsas won't boot with 2.6.35-rc2
>
> With 2.6.35-rc2 one of my LS21 boxes stopped booting. I'm seeing:
>
> Fusion MPT SAS Host driver 3.04.15
> mptsas 0000:03:04.0: can't find IRQ for PCI INT A; probably buggy MP
> table
John,

I have seen similar issue in past and It was solve at pci subsystem level.
I am not sure what was a change but yes it was IRQ mapping issue at pci subsystem of OS.

So my suggestion to you is use 2.6.34 where things are working fine and see what a behavior is with
3.04.14 driver and 3.04.15 driver.


~Kashyap


> mptbase: ioc0: Initiating bringup
> ioc0: LSISAS1064 A3: Capabilities={Initiator}
> mptbase: ioc0: WARNING - Issuing Reset from mpt_config!!
> mptbase: ioc0: Attempting Retry Config request type 0x1, page 0x2,
> action 0
> mptbase: ioc0: WARNING - Issuing Reset from mpt_config!!
> mptbase: ioc0: Initiating recovery
> mptbase: ioc0: Attempting Retry Config request type 0x1, page 0x2,
> action 0
>
>
>
> Where as 2.6.34 with the same .config boots fine:
>
> Fusion MPT SAS Host driver 3.04.14
> mptsas 0000:03:04.0: PCI INT A -> GSI 19 (level, low) -> IRQ 19
> mptbase: ioc0: Initiating bringup
> ioc0: LSISAS1064 A3: Capabilities={Initiator}
> scsi0 : ioc0: LSISAS1064 A3, FwRev=01125400h, Ports=1, MaxQ=511, IRQ=19
> mptsas: ioc0: attaching ssp device: fw_channel 0, fw_id 0, phy 0,
> sas_addr 0x5000c500021cbc49
> scsi 0:0:0:0: Direct-Access IBM-ESXS ST973401SS B51D PQ: 0
> ANSI: 5
> sd 0:0:0:0: Attached scsi generic sg0 type 0
> Fusion MPT misc device (ioctl) driver 3.04.14
> sd 0:0:0:0: [sda] 143374000 512-byte logical blocks: (73.4 GB/68.3 GiB)
> sd 0:0:0:0: [sda] Write Protect is off
> sd 0:0:0:0: [sda] Write cache: disabled, read cache: enabled, supports
> DPO and FUA
> mptctl: Registered with Fusion MPT base driver
> mptctl: /dev/mptctl @ (major,minor=10,220)
> ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
> ACPI: PCI Interrupt Link [LPUS] enabled at IRQ 5
> ehci_hcd 0000:00:03.2: PCI INT A -> Link[LPUS] -> GSI 5 (level, low) ->
> IRQ 5
> ehci_hcd 0000:00:03.2: EHCI Host Controller
> ehci_hcd 0000:00:03.2: new USB bus registered, assigned bus number 1
> sda: sda1 sda2 sda3 sda4
> ...
>
>
> Although from the warning, this may be irq routing related, not driver
> related. Any suggestions?
>
> thanks
> -john
>
>

\
 
 \ /
  Last update: 2010-06-08 07:11    [W:0.046 / U:2.856 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site