lkml.org 
[lkml]   [2010]   [Jun]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [RFC][PATCH 6/8] perf: Per PMU disable
On Fri, Jun 18, 2010 at 09:11:58AM +0200, Peter Zijlstra wrote:
> On Fri, 2010-06-18 at 04:14 +0200, Frederic Weisbecker wrote:
> > On Wed, Jun 16, 2010 at 06:00:33PM +0200, Peter Zijlstra wrote:
> > > +static void armpmu_pmu_enable(struct pmu *pmu)
> > > {
> > > +static void powerpc_pmu_pmu_disable(struct pmu *pmu)
> > > {
> > > +static void fsl_emb_pmu_pmu_disable(struct pmu *pmu)
> > > {
> > > +static void sh_pmu_pmu_enable(struct pmu *pmu)
> > > +{
> > > +static void sparc_pmu_pmu_enable(struct pmu *pmu)
> > > {
> > > +static void x86_pmu_pmu_disable(struct pmu *pmu)
> > > {
> >
> >
> > These namings are really bad. Why not just using pmu once
> > in each names? x86_pmu_enable, etc...
>
> Because some of those were already taken:
>
> static const struct pmu pmu = {
> .enable = x86_pmu_enable,
> .disable = x86_pmu_disable,


Then those should be renamed into x86_event_enable or so.



\
 
 \ /
  Last update: 2010-06-22 18:23    [from the cache]
©2003-2011 Jasper Spaans