lkml.org 
[lkml]   [2010]   [Jun]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [Xen-devel] [PATCH 06/12] Allow xen platform pci device to be compiled as a module
On Tue, 15 Jun 2010, Jeremy Fitzhardinge wrote:
> On 06/14/2010 10:20 PM, Konrad Rzeszutek Wilk wrote:
> >> -static inline unsigned int max_nr_grant_frames(void)
> >> +unsigned int gnttab_max_nr_grant_frames(void)
> >> {
> >> unsigned int xen_max = __max_nr_grant_frames();
> >>
> >> @@ -444,6 +445,7 @@ static inline unsigned int max_nr_grant_frames(void)
> >> return boot_max_nr_grant_frames;
> >> return xen_max;
> >> }
> >> +EXPORT_SYMBOL_GPL(gnttab_max_nr_grant_frames);
> >>
> > Prefix the name with 'xen_' ? That is a mouthfull thought:
> >
> > Xen Grant Table Max Nr Grant Frames. How about 'xen_gnttab_max_frames' ?
> >
>
> Unfortunately the gnttab API is generally lacking xen_ prefixes. It's
> better to keep this consistent, and then maybe sort them all out together.
>


I renamed it to gnttab_max_grant_frames for now.


\
 
 \ /
  Last update: 2010-06-17 17:47    [from the cache]
©2003-2011 Jasper Spaans