lkml.org 
[lkml]   [2010]   [May]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: [2.6.31.13] Build failure at arch/x86/kernel/apic/io_apic.c
    On Mon, May 03, 2010 at 10:50:41AM -0700, Yinghai wrote:
    > On 05/03/2010 10:44 AM, Greg KH wrote:
    > > On Mon, May 03, 2010 at 10:16:06AM -0700, Yinghai wrote:
    > >> On 05/01/2010 11:07 AM, Greg KH wrote:
    > >>> On Mon, Apr 12, 2010 at 01:10:59PM +0900, Tetsuo Handa wrote:
    > >>>> Commit d539e5576605d048e6aeb21cbe3a8e71dc5eea81 "x86: Fix SCI on IOAPIC != 0"
    > >>>> introduced "void setup_IO_APIC_irq_extra(u32 gsi)" which calls
    > >>>> mp_find_ioapic() and mp_find_ioapic_pin().
    > >>>>
    > >>>> This commit does not compile if CONFIG_X86_IO_APIC=y and CONFIG_ACPI=n .
    > >>>
    > >>> Why would you want to build without ACPI on any modern system? Anyway,
    > >>> have a fix for this?
    > >>>
    > >> maybe just put #ifdef CONFIG_ACPI around the callee etc?
    > >
    > > Ick. How was it solved upstream?
    > >
    >
    > those two functions are moved to arch/x86/kernel/apic/io_apic.c
    >
    > maybe you can put that patch to 2.6.31.xx?

    Ah, yeah, that might be good, I'll see about that, if I do another
    .31-stable release, which right now, I do not think so.

    thanks,

    greg k-h


    \
     
     \ /
      Last update: 2010-05-03 20:03    [W:0.021 / U:1.136 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site