lkml.org 
[lkml]   [2010]   [May]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 11/11] Unplug emulated disks and nics
On Tue, 25 May 2010, Jeremy Fitzhardinge wrote:
> Could you give this a bit more of a descriptive name, type and/or
> comment? What is it indicating about the xen_platform_pci driver? That
> it has been detected? That it is in use? That it can be used? Is it
> boolean, or can it have any value?
>
>

It is boolean and it signals that the xen platform pci device can be
used. I'll add a comment and rename it to xen_platform_pci_enabled.


> > + */
> > +
> > +#ifndef _XEN_PLATFORM_PCI_H
> > +#define _XEN_PLATFORM_PCI_H
> > +
> > +#include <linux/version.h>
> >
> Why?
>

It is needed for LINUX_VERSION_CODE, see below:

> > +
> > +#define XEN_IOPORT_MAGIC_VAL 0x49d2
> > +#define XEN_IOPORT_LINUX_PRODNUM 0xffff
> > +#define XEN_IOPORT_LINUX_DRVVER ((LINUX_VERSION_CODE << 8) + 0x0)
> > +
> > +extern int xen_platform_pci;
> >
>
> I still think these headers should be folded together. There's no point
> in having them separate. They describe an ABI, so there's no need to
> keep the files in sync with the master Xen sources (since the ABI will
> never change).

All right, I also agree with the other comments.


\
 
 \ /
  Last update: 2010-05-26 14:25    [W:0.170 / U:8.620 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site