Messages in this thread Patch in this message |  | | Date | Sun, 2 May 2010 08:03:54 +0200 | | From | Borislav Petkov <> | | Subject | [PATCH] ring-buffer: Wrap open-coded WARN_ONCE |
| |
Wrap open-coded WARN_ONCE functionality into the equivalent macro.
Signed-off-by: Borislav Petkov <bp@alien8.de> --- kernel/trace/ring_buffer.c | 14 +++++--------- 1 files changed, 5 insertions(+), 9 deletions(-)
diff --git a/kernel/trace/ring_buffer.c b/kernel/trace/ring_buffer.c index 41ca394..19a7407 100644 --- a/kernel/trace/ring_buffer.c +++ b/kernel/trace/ring_buffer.c @@ -1979,17 +1979,13 @@ rb_add_time_stamp(struct ring_buffer_per_cpu *cpu_buffer, u64 *ts, u64 *delta) { struct ring_buffer_event *event; - static int once; int ret; - if (unlikely(*delta > (1ULL << 59) && !once++)) { - printk(KERN_WARNING "Delta way too big! %llu" - " ts=%llu write stamp = %llu\n", - (unsigned long long)*delta, - (unsigned long long)*ts, - (unsigned long long)cpu_buffer->write_stamp); - WARN_ON(1); - } + WARN_ONCE(*delta > (1ULL << 59), + KERN_WARNING "Delta way too big! %llu ts=%llu write stamp = %llu\n", + (unsigned long long)*delta, + (unsigned long long)*ts, + (unsigned long long)cpu_buffer->write_stamp); /* * The delta is too big, we to add a -- 1.7.0.3
-- Regards/Gruss, Boris.
|  |