[lkml]   [2010]   [May]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: [PATCH 07/10] generic rwsem: implement down_read_critical() / up_read_critical()
    On Mon, May 17, 2010 at 03:44:24PM -0700, Linus Torvalds wrote:
    > You didn't update the comment for the new name here...
    > > - when the rwsem is write owned, down_read_unfair() callers get queued in
    > > front of threads trying to acquire the rwsem by other means.
    > .. or here. In this case, it really is more about "unfairness", but I'm
    > not convinced it should be so in the naming anyway, even if internally it
    > might be __down_read_unfair. "critical" I think covers both.

    Gah! Sorry for missing the comment updates. I agree with you on the naming,
    I just didn't remember about the comment.

    Will send identical patch with the correct comment as reply to this.

    > Anyway, the series looks mostly acceptable to me in this form. I think it
    > conceptually works out, and I think that the non-preemption guarantee
    > should mean that starvation of writers is not likely an issue. However,
    > I'd definitely like some second opinions on it. I'm not going to apply
    > this series without acks from people. So you should try to convince DavidH
    > too that this actually really does matter and makes sense.

    I'll see what I can do here. Thanks !

    Michel "Walken" Lespinasse
    A program is never fully debugged until the last user dies.

     \ /
      Last update: 2010-05-18 01:15    [W:0.025 / U:3.408 seconds]
    ©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site