lkml.org 
[lkml]   [2010]   [May]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    SubjectRe: [BUG] SLOB breaks Crypto
    From
    On Fri, Mar 19, 2010 at 02:33, Herbert Xu <herbert@gondor.apana.org.au> wrote:
    > On Thu, Mar 18, 2010 at 10:24:41PM +0100, michael-dev@fami-braun.de wrote:
    >>
    >> Pekka Enberg schrieb:
    >> > Even with CONFIG_DEBUG_SLAB enabled or with CONFIG_SLUB and
    >> > CONFIG_SLUB_DEBUG_ON?
    >>
    >> no, these options have not been / are not enabled.
    >
    > Can you please try it with those options enabled? That will tell
    > us if there is some latent bug in the crypto layer that only shows
    > up right away under SLOB.

    After seeing a posting from Nemoto-san on the linux-mips list (should
    show up soon on
    http://www.linux-mips.org/archives/linux-mips/2010-05/threads.html),
    I'm wondering if these defaults are the culprit;

    mm/slab.c:#define ARCH_KMALLOC_MINALIGN __alignof__(unsigned long long)
    mm/slob.c:#define ARCH_KMALLOC_MINALIGN __alignof__(unsigned long)
    mm/slub.c:#define ARCH_KMALLOC_MINALIGN __alignof__(unsigned long long)

    Note that some platforms override this.

    Gr{oetje,eeting}s,
    Geert

    --
    Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@linux-m68k.org

    In personal conversations with technical people, I call myself a hacker. But
    when I'm talking to journalists I just say "programmer" or something like that.
    -- Linus Torvalds


    \
     
     \ /
      Last update: 2010-05-17 18:19    [from the cache]
    ©2003-2014 Jasper Spaans. hosted at Digital Ocean