lkml.org 
[lkml]   [2010]   [May]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    Patch in this message
    /
    Date
    From
    Subject[tip:perf/core] perf probe: Check older elfutils and set NO_DWARF
    Commit-ID:  6b3c4ef50441e85dc9b2c9b67e95e8ad1185c15e
    Gitweb: http://git.kernel.org/tip/6b3c4ef50441e85dc9b2c9b67e95e8ad1185c15e
    Author: Masami Hiramatsu <mhiramat@redhat.com>
    AuthorDate: Tue, 11 May 2010 00:59:53 -0400
    Committer: Arnaldo Carvalho de Melo <acme@redhat.com>
    CommitDate: Tue, 11 May 2010 12:43:11 -0300

    perf probe: Check older elfutils and set NO_DWARF

    Check whether elfutils is older than 0.138 (from which version checking
    routine has been introduced). And if so, set NO_DWARF because it is hard
    to check the API dependency without version checking.

    Signed-off-by: Masami Hiramatsu <mhiramat@redhat.com>
    Reported-by: Robert Richter <robert.richter@amd.com>
    Cc: Robert Richter <robert.richter@amd.com>
    Cc: Ingo Molnar <mingo@elte.hu>
    LKML-Reference: <20100511045953.9913.19485.stgit@localhost6.localdomain6>
    Signed-off-by: Arnaldo Carvalho de Melo <acme@redhat.com>
    ---
    tools/perf/Makefile | 4 ++--
    1 files changed, 2 insertions(+), 2 deletions(-)

    diff --git a/tools/perf/Makefile b/tools/perf/Makefile
    index 0ef5cfe..b28bb73 100644
    --- a/tools/perf/Makefile
    +++ b/tools/perf/Makefile
    @@ -506,8 +506,8 @@ PERFLIBS = $(LIB_FILE)
    -include config.mak

    ifndef NO_DWARF
    -ifneq ($(shell sh -c "(echo '\#include <dwarf.h>'; echo '\#include <libdw.h>'; echo 'int main(void) { Dwarf *dbg; dbg = dwarf_begin(0, DWARF_C_READ); return (long)dbg; }') | $(CC) -x c - $(ALL_CFLAGS) -I/usr/include/elfutils -ldw -lelf -o $(BITBUCKET) $(ALL_LDFLAGS) $(EXTLIBS) "$(QUIET_STDERR)" && echo y"), y)
    - msg := $(warning No libdw.h found or old libdw.h found, disables dwarf support. Please install elfutils-devel/libdw-dev);
    +ifneq ($(shell sh -c "(echo '\#include <dwarf.h>'; echo '\#include <libdw.h>'; echo '\#include <version.h>'; echo '\#ifndef _ELFUTILS_PREREQ'; echo '\#error'; echo '\#endif'; echo 'int main(void) { Dwarf *dbg; dbg = dwarf_begin(0, DWARF_C_READ); return (long)dbg; }') | $(CC) -x c - $(ALL_CFLAGS) -I/usr/include/elfutils -ldw -lelf -o $(BITBUCKET) $(ALL_LDFLAGS) $(EXTLIBS) "$(QUIET_STDERR)" && echo y"), y)
    + msg := $(warning No libdw.h found or old libdw.h found or elfutils is older than 0.138, disables dwarf support. Please install new elfutils-devel/libdw-dev);
    NO_DWARF := 1
    endif # Dwarf support
    endif # NO_DWARF

    \
     
     \ /
      Last update: 2010-05-12 10:43    [W:4.028 / U:0.020 seconds]
    ©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site