lkml.org 
[lkml]   [2010]   [May]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] power: Rename get_current to fix build failure / name conflict
Peter Huewe wrote:
> From: Peter Huewe <peterhuewe@gmx.de>
>
> This patch changes the name of get_current function pointer to
> get_battery_current to resolve a name conflict with the get_current
> macro defined in current.h.
>
> This conflict resulted in a build-failure[1] for the sh4 arch
> allyesconfig which is resolved by this patch.

Ah, didn't think of that. Thanks.
Acked-by: Ryan Mallon <ryan@bluewatersys.com>

> To be consistent the other function pointers (_voltage,_capacity) were
> renamed too.
>
> Signed-off-by: Peter Huewe <peterhuewe@gmx.de>
> ---
> KernelVersion: linux-next 20100512
> References:
> [1] http://kisskb.ellerman.id.au/kisskb/buildresult/2572665/
>
> drivers/power/ds2782_battery.c | 29 ++++++++++++++---------------
> 1 files changed, 14 insertions(+), 15 deletions(-)
>
> diff --git a/drivers/power/ds2782_battery.c b/drivers/power/ds2782_battery.c
> index d762a0c..9b3b4b7 100644
> --- a/drivers/power/ds2782_battery.c
> +++ b/drivers/power/ds2782_battery.c
> @@ -43,10 +43,9 @@
> struct ds278x_info;
>
> struct ds278x_battery_ops {
> - int (*get_current)(struct ds278x_info *info, int *current_uA);
> - int (*get_voltage)(struct ds278x_info *info, int *voltage_uA);
> - int (*get_capacity)(struct ds278x_info *info, int *capacity_uA);
> -
> + int (*get_battery_current)(struct ds278x_info *info, int *current_uA);
> + int (*get_battery_voltage)(struct ds278x_info *info, int *voltage_uA);
> + int (*get_battery_capacity)(struct ds278x_info *info, int *capacity_uA);
> };
>
> #define to_ds278x_info(x) container_of(x, struct ds278x_info, battery)
> @@ -213,11 +212,11 @@ static int ds278x_get_status(struct ds278x_info *info, int *status)
> int current_uA;
> int capacity;
>
> - err = info->ops->get_current(info, &current_uA);
> + err = info->ops->get_battery_current(info, &current_uA);
> if (err)
> return err;
>
> - err = info->ops->get_capacity(info, &capacity);
> + err = info->ops->get_battery_capacity(info, &capacity);
> if (err)
> return err;
>
> @@ -246,15 +245,15 @@ static int ds278x_battery_get_property(struct power_supply *psy,
> break;
>
> case POWER_SUPPLY_PROP_CAPACITY:
> - ret = info->ops->get_capacity(info, &val->intval);
> + ret = info->ops->get_battery_capacity(info, &val->intval);
> break;
>
> case POWER_SUPPLY_PROP_VOLTAGE_NOW:
> - ret = info->ops->get_voltage(info, &val->intval);
> + ret = info->ops->get_battery_voltage(info, &val->intval);
> break;
>
> case POWER_SUPPLY_PROP_CURRENT_NOW:
> - ret = info->ops->get_current(info, &val->intval);
> + ret = info->ops->get_battery_current(info, &val->intval);
> break;
>
> case POWER_SUPPLY_PROP_TEMP:
> @@ -307,14 +306,14 @@ enum ds278x_num_id {
>
> static struct ds278x_battery_ops ds278x_ops[] = {
> [DS2782] = {
> - .get_current = ds2782_get_current,
> - .get_voltage = ds2782_get_voltage,
> - .get_capacity = ds2782_get_capacity,
> + .get_battery_current = ds2782_get_current,
> + .get_battery_voltage = ds2782_get_voltage,
> + .get_battery_capacity = ds2782_get_capacity,
> },
> [DS2786] = {
> - .get_current = ds2786_get_current,
> - .get_voltage = ds2786_get_voltage,
> - .get_capacity = ds2786_get_capacity,
> + .get_battery_current = ds2786_get_current,
> + .get_battery_voltage = ds2786_get_voltage,
> + .get_battery_capacity = ds2786_get_capacity,
> }
> };
>


--
Bluewater Systems Ltd - ARM Technology Solution Centre

Ryan Mallon 5 Amuri Park, 404 Barbadoes St
ryan@bluewatersys.com PO Box 13 889, Christchurch 8013
http://www.bluewatersys.com New Zealand
Phone: +64 3 3779127 Freecall: Australia 1800 148 751
Fax: +64 3 3779135 USA 1800 261 2934


\
 
 \ /
  Last update: 2010-05-13 02:35    [W:1.191 / U:23.540 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site