lkml.org 
[lkml]   [2010]   [May]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] HID:magicmouse: This fixes a connection problem with the magicmouse.
On Wed, 12 May 2010, Justin P. Mattock wrote:

> > > > > --- a/drivers/hid/hid-magicmouse.c
> > > > > +++ b/drivers/hid/hid-magicmouse.c
> > > > > @@ -354,7 +354,7 @@ static int magicmouse_probe(struct hid_device
> > > > > *hdev,
> > > > > goto err_free;
> > > > > }
> > > > >
> > > > > - ret = hid_hw_start(hdev, HID_CONNECT_DEFAULT&
> > > > > ~HID_CONNECT_HIDINPUT);
> > > > > + ret = hid_hw_start(hdev, HID_CONNECT_DEFAULT);
> > > > >
> > > > >
> > > > This is not particularly right, as we'll end up having dangling
> > > > input device.
> > > >
> > > > The problem is, that when HIDRAW is not set, hid_hw_start()
> > > > returns ENODEV as no subsystem has claimed the device, and probe
> > > > routine bails out. Which is not what we want.
> > > >
> > > > Does the testing patch below fix the problems you are seeing?
> > > >
> > > works good.. rebooted a few times mouse connects. suspended a few times
> > > mouse reconnects.
> > >
> > I'd be glad if you could also double-check that device removal and
> > re-connecting it works well as well with this patch.
> >
> with test I did different techniques,
> 1) regular suspend(leave device on)
> 2)suspend then shut off device
> 3)shut off device then suspend
> all of these techniques work properly

Thanks for reporting and testing, I have queued the patch.

--
Jiri Kosina
SUSE Labs, Novell Inc.


\
 
 \ /
  Last update: 2010-05-12 16:05    [W:0.033 / U:20.416 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site