lkml.org 
[lkml]   [2010]   [Apr]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: Arch specific mmap attributes (Was: mprotect pgprot handling weirdness)
From
Date
On Tue, 2010-04-06 at 15:24 +0900, KOSAKI Motohiro wrote:

> I guess you haven't catch my intention. I didn't say we have to remove
> PROT_SAO and VM_SAO.
> I mean mmap(PROT_SAO) is ok, it's only append new flag, not change exiting
> flags meanings. I'm only against mprotect(PROT_NONE) turn off PROT_SAO
> implicitely.
>
> IOW I recommend we use three syscall
> mmap() create new mappings
> mprotect() change a protection of mapping (as a name)
> mattribute(): (or similar name)
> change an attribute of mapping (e.g. PROT_SAO or
> another arch specific flags)
>
> I'm not against changing mm/protect.c for PROT_SAO.

Ok, I see. No biggie. The main deal remains how we want to do that
inside the kernel :-) I think the less horrible options here are
to either extend vm_flags to always be 64-bit, or add a separate
vm_map_attributes flag, and add the necessary bits and pieces to
prevent merge accross different attribute vma's.

The more I try to hack it into vm_page_prot, the more I hate that
option.

Cheers
Ben.




\
 
 \ /
  Last update: 2010-04-06 09:33    [W:0.155 / U:1.032 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site