[lkml]   [2010]   [Apr]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 8/8] [watchdog] separate touch_nmi_watchdog code path from touch_watchdog
On Fri, Apr 23, 2010 at 12:13:36PM -0400, Don Zickus wrote:
> When I combined the nmi_watchdog (hardlockup) and softlockup code, I
> also combined the paths the touch_watchdog and touch_nmi_watchdog took.
> This may not be the best idea as pointed out by Frederic W., that the
> touch_watchdog case probably should not reset the hardlockup count.
> Therefore the patch belows falls back to the previous idea of keeping
> the touch_nmi_watchdog a superset of the touch_watchdog case.
> Signed-off-by: Don Zickus <>

Good. But now that we have this, it doesn't make sense anymore
to have the big rename touch_softlockup_watchdog() into touch_watchdog().

I know it was me who advised you to do this big rename, but that was
before I realised touching the softlockup shouldn't mean touching nmi
watchdog too.

I'm sorry about this but this big rename doesn't make sense anymore.

Can we drop touch_watchdog() and keep only the two previous APIs we had

1) we avoid a big patch very likely to bring conflicts everywhere
2) touch_softlockup_watchdog() is much more self-explanatory in what
it does. People will have less doubts about what happens when they
call this.


 \ /
  Last update: 2010-04-28 14:51    [W:0.075 / U:2.812 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site