lkml.org 
[lkml]   [2010]   [Mar]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [alsa-devel] [PATCH]Support MCP89 and GT21x hdmi audio
CC Jaroslav, maybe he has some idea on

pcm_hw.c: snd_pcm_hw_delay() SNDRV_PCM_IOCTL_DELAY failed.

On Mon, Mar 08, 2010 at 12:35:37PM +0800, Wei Ni wrote:
> Hi,
> Because I don't have GT220 card on hand, I didn't test it yet.
> So I didn't add this card to the patch file. I think you could add it after
> you test it.
>
> About the warning messages, I don't know why.
> May be some others can answer.
>
> Thanks
> Wei.
> nvpublic
>
> -----Original Message-----
> From: VDR User [mailto:user.vdr@gmail.com]
> Sent: Monday, March 08, 2010 3:22 AM
> To: Wei Ni
> Cc: Takashi Iwai; akpm; alsa-devel; Wu Fengguang; linux-kernel; Pavel Hofman
> Subject: Re: [alsa-devel] [PATCH]Support MCP89 and GT21x hdmi audio
>
> I think this may be relevant to this subject, if not then my apologies.
>
> I've just installed a GT220 card and was able to get audio-over-hdmi
> working by compiling the snapshot drivers from 20100307 which contain
> Wei's new code. I further had to patch the driver to recognize my
> card with:
>
> --- alsa-driver-orig/alsa-kernel/pci/hda/patch_nvhdmi.c 2010-03-06
> 18:00:12.000000000 -0800
> +++ alsa-driver/alsa-kernel/pci/hda/patch_nvhdmi.c 2010-03-06
> 18:02:00.000000000 -0800
> @@ -1335,6 +1335,8 @@ static struct hda_codec_preset snd_hda_p
> .patch = patch_nvhdmi_8ch_89 },
> { .id = 0x10de000b, .name = "GT21x HDMI",
> .patch = patch_nvhdmi_8ch_89 },
> + { .id = 0x10de000a, .name = "GT220 HDMI",
> + .patch = patch_nvhdmi_8ch_89 },
> { .id = 0x10de000d, .name = "GT240 HDMI",
> .patch = patch_nvhdmi_8ch_89 },
> {} /* terminator */
> @@ -1347,6 +1349,7 @@ MODULE_ALIAS("snd-hda-codec-id:10de0006"
> MODULE_ALIAS("snd-hda-codec-id:10de0007");
> MODULE_ALIAS("snd-hda-codec-id:10de0067");
> MODULE_ALIAS("snd-hda-codec-id:10de8001");
> +MODULE_ALIAS("snd-hda-codec-id:10de000a");
> MODULE_ALIAS("snd-hda-codec-id:10de000c");
> MODULE_ALIAS("snd-hda-codec-id:10de000b");
> MODULE_ALIAS("snd-hda-codec-id:10de000d");
>
> This seems to work fine when running VDR but if I do anything else
> like upgrade packages, compile something, or maybe create a bz2, then
> I start to see _a lot_ of the following in my xine log:
>
> pcm_hw.c: snd_pcm_hw_delay() SNDRV_PCM_IOCTL_DELAY failed.
>
> With the old code this didn't happen. However, my setup was an 8400gs
> using SPDIF OUT from my mainboard to SPDIF IN on the card. Then using
> a dvi->hdmi cable into the tv.
>
> Again, I apologize if I'm posting this in the wrong place.
>
> Best regards.


\
 
 \ /
  Last update: 2010-03-08 05:49    [W:0.093 / U:2.884 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site