lkml.org 
[lkml]   [2010]   [Mar]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] rcu: don't call rcu_preempt_note_context_switch() in rcu_check_callbacks()
Paul E. McKenney wrote:
> On Mon, Mar 29, 2010 at 10:47:59AM +0800, Lai Jiangshan wrote:
>> Content-Type: text/plain; charset=UTF-8
>> Content-Transfer-Encoding: 7bit
>>
>>
>> Even though in user mode or idle mode, rcu_check_callbacks() is not
>> context switch, so we don't call rcu_preempt_note_context_switch()
>> in rcu_check_callbacks().
>>
>> Though there is no harm that calls rcu_preempt_note_context_switch()
>> in rcu_check_callbacks(), but it is waste.
>>
>> rcu_check_callbacks()
>> rcu_sched_qs()
>> rcu_preempt_note_context_switch()
>> Now, ->rcu_read_lock_nesting == 0, so we just calls
>> rcu_preempt_qs(), but, rcu_preempt_check_callbacks()
>> will call it again and set the ->rcu_read_unlock_special
>> correct again.
>>
>> So let rcu_preempt_check_callbacks() handle things for us.
>
> Nice!!!
>
> But how about naming the new function that invokes
> rcu_preempt_note_context_switch() something like
> rcu_sched_note_context_switch(), and then leaving the
> name of rcu_sched_qs() the same (rather than changing
> it to __rcu_sched_qs(), as below)?
>
> This way, the names clearly call out what the function
> is doing.
>

If I understand right, it will become this:

schedule() / run_ksoftirqd() / rcu_needs_cpu()
rcu_sched_note_context_switch()
rcu_sched_qs()
rcu_preempt_note_context_switch()

Right?




\
 
 \ /
  Last update: 2010-03-30 11:45    [W:0.104 / U:0.972 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site