lkml.org 
[lkml]   [2010]   [Mar]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH 07/11] Memory compaction core
Date
> On Wed, Mar 17, 2010 at 07:31:53PM +0900, KOSAKI Motohiro wrote:
> > nit
> >
> > > +static int compact_zone(struct zone *zone, struct compact_control *cc)
> > > +{
> > > + int ret = COMPACT_INCOMPLETE;
> > > +
> > > + /* Setup to move all movable pages to the end of the zone */
> > > + cc->migrate_pfn = zone->zone_start_pfn;
> > > + cc->free_pfn = cc->migrate_pfn + zone->spanned_pages;
> > > + cc->free_pfn &= ~(pageblock_nr_pages-1);
> > > +
> > > + for (; ret == COMPACT_INCOMPLETE; ret = compact_finished(zone, cc)) {
> > > + unsigned long nr_migrate, nr_remaining;
> > > + if (!isolate_migratepages(zone, cc))
> > > + continue;
> > > +
> > > + nr_migrate = cc->nr_migratepages;
> > > + migrate_pages(&cc->migratepages, compaction_alloc,
> > > + (unsigned long)cc, 0);
> > > + update_nr_listpages(cc);
> > > + nr_remaining = cc->nr_migratepages;
> > > +
> > > + count_vm_event(COMPACTBLOCKS);
> >
> > V1 did compaction per pageblock. but current patch doesn't.
> > so, Is COMPACTBLOCKS still good name?
>
> It's not such a minor nit. I wondered about that myself but it's still a
> block - just not a pageblock. Would COMPACTCLUSTER be a better name as it's
> related to COMPACT_CLUSTER_MAX?

I've looked at this code again. honestly I'm a abit confusing even though both your
suggestions seems reasonable.

now COMPACTBLOCKS is tracking #-of-called-migrate_pages. but I can't imazine
how to use it. can you please explain this ststics purpose? probably this is only useful
when conbination other stats, and the name should be consist with such combination one.


> > > + count_vm_events(COMPACTPAGES, nr_migrate - nr_remaining);
> > > + if (nr_remaining)
> > > + count_vm_events(COMPACTPAGEFAILED, nr_remaining);
> > > +
> > > + /* Release LRU pages not migrated */
> > > + if (!list_empty(&cc->migratepages)) {
> > > + putback_lru_pages(&cc->migratepages);
> > > + cc->nr_migratepages = 0;
> > > + }
> > > +
> > > + mod_zone_page_state(zone, NR_ISOLATED_ANON, -cc->nr_anon);
> > > + mod_zone_page_state(zone, NR_ISOLATED_FILE, -cc->nr_file);
> >
> > I think you don't need decrease this vmstatistics here. migrate_pages() and
> > putback_lru_pages() alredy does.
> >
>
> Hmm, I do need to decrease the vmstats here but not by this much. The
> pages migrated need to be accounted for but not the ones that failed. I
> missed this because migration was always succeeding. Thanks. I'll get it
> fixed for V5

thanks.




\
 
 \ /
  Last update: 2010-03-18 03:39    [W:0.091 / U:2.348 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site