lkml.org 
[lkml]   [2010]   [Mar]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: Possible bug in eeepc-laptop.c - EeePC 900
From
Hi.

On Tue, Mar 9, 2010 at 11:58 PM, Fabio Comolli <fabio.comolli@gmail.com> wrote:
> Hi.
> I have an EeePC 900 running 2.6.34-rc1.
>
> If I boot it on AC the cpu runs at full speed, 900MHz; if I boot it on
> battery it runs only at 630Mhz. Plugging / unplugging the AC does not
> change the cpu frequency. Only a reboot can change the situation.
>
> I already tried to echo 0 or 1 to the
> /sys/devices/platform/eeepc/cpufv file; no effects, even if the file
> changes its value.
>
> This is not a regression from 2.6.33: this behavior is also present in
> that version.
>
> Does this ring any bells? This is really annoying, especially when
> trying to watch a movie on battery. Also 3D apps show a 30%
> performance drop, as expected.
>
> Regards,
> Fabio

Well, it turns out that this is indeed a regression, but I don't know
from which kernel version.
I reverted (not cleanly) this patch:

http://patchwork.kernel.org/patch/28591

and now

echo 1 > /sys/devices/platform/eeepc/cpufv

enables the powersave mode and

echo 0 > /sys/devices/platform/eeepc/cpufv

enables the performance mode.

Tested with the non-benchmark glxgears (275 frames/sec in powersave
mode and 405 in performance mode) and stellarium (14 frames and 20
frames).

Regards,
Fabio


\
 
 \ /
  Last update: 2010-03-11 22:31    [W:0.054 / U:4.660 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site