[lkml]   [2010]   [Mar]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH] x86: namespace some I/O APIC related structures and functions.
Date writes:

> From: Ian Campbell <>
> It is not obvious that certain functions relate specifically to the
> I/O APIC. Rename structures and functions as follows:
> struct irq_cfg -> struct ioapic_irq_cfg
> irq_cfg() -> ioapic_irq_cfg()
> assign_irq_vector() -> ioapic_assign_irq_vector()
> send_cleanup_vector() -> ioapic_send_cleanup_vector()
> There is a slight preference towards ioapic vs io_apic in the current
> code (563 occurances vs 146) so I went with that.

The rename is wrong. Only the optional irq_2_pin list in struct
irq_cfg is specific to ioapics.

The rest of the fields are all about the architectural vector based
interrupt delivery system of x86. Branding that structure with ioapic
is strongly misleading.

x86_irq_cfg might be an appropriate rename.


 \ /
  Last update: 2010-03-10 18:11    [W:0.107 / U:2.828 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site