lkml.org 
[lkml]   [2010]   [Mar]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [Xen-devel] [PATCH 3/7] xen/hvm: Xen PV extension of HVM initialization
On 03/01/2010 05:38 PM, Sheng Yang wrote:
>> Why use this? Why not just set the domain type to HVM, and leave the
>> "status" field as a bitset of available paravirtualizations?
>>
> A annoy thing in pv drivers is that it would test if the domain type is _NOT_
> XEN_NATIVE. So set the domain to XEN_HVM_DOMAIN would result in PV driver
> initialization then probably panic. Maybe we can do something to PV drivers,
> as patch 6 and a part of patch 7.
>

In that case, change them to specifically test for PV until they're
ready to deal with an HVM environment.

>
> Part of pv_ops are overlapped. I would try if a new file would bring much
> duplicate.
>

It shouldn't do; un-static things if necessary.

>>> + .align PAGE_SIZE_asm
>>> +ENTRY(shared_info_page)
>>> + .skip PAGE_SIZE_asm
>>> +.popsection
>>>
>> Why does this need to be defined in asm? Can't it be either allocated
>> or defined in C?
>>
> I think we need a aligned page, as hypercall page.
>

That can be declared in C with the __page_aligned_bss annotation. And
couldn't you dynamically allocate it with the bootmem allocator?

>> I think "status" is a misnomer here. Isn't it specifically a set of PV
>> features which are active?
>>
> Could you give a suggestion of the name? I am not a native English speaker...
>

xen_hvm_pv_features.

J


\
 
 \ /
  Last update: 2010-03-02 02:45    [W:0.088 / U:0.032 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site