lkml.org 
[lkml]   [2010]   [Feb]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 15/35] x86: make 64 bit use early_res instead of bootmem before slab
On 02/09/2010 02:33 PM, Andrew Morton wrote:
>
> err, crap, yeah.
>
> It would be nice to fix all this up, and get the private round_up()
> stuff out of x86 and into kernel.h.
>
> The present naming scheme is ghastly:
>
> ALIGN
> DIV_ROUND_UP
> roundup
> round_up
> round_down
>
> Where round_up and ALIGN are kinda maybe the same.
>

Yes indeed. It seems to be something for a separate patchset, though,
since it will touch stuff across a lot of code.

-hpa



\
 
 \ /
  Last update: 2010-02-09 23:47    [W:0.221 / U:0.416 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site