lkml.org 
[lkml]   [2010]   [Feb]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 15/35] x86: make 64 bit use early_res instead of bootmem before slab
On 02/09/2010 01:45 PM, H. Peter Anvin wrote:
>>
>> /**
>> * roundup_pow_of_two - round the given value up to nearest power of two
>> * @n - parameter
>> *
>
> Hah. Naming can be a real headache with small, common operations.
>
> At the same time, round_up() versus roundup() is a source of some
> serious confusion. roundup_bin() might be a better name... I don't know.
>

On the other hand... if we're doing a renaming patchset at some point
(which would be necessary anyway, since all these interfaces have
users), perhaps we should change roundup_pow_of_two() to
next_power_of_two() or something like that.

-hpa



\
 
 \ /
  Last update: 2010-02-09 22:51    [W:0.086 / U:2.208 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site