lkml.org 
[lkml]   [2010]   [Feb]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 15/35] x86: make 64 bit use early_res instead of bootmem before slab
On 02/09/2010 01:37 PM, Yinghai Lu wrote:
> On 02/09/2010 12:26 PM, Andrew Morton wrote:
>> On Tue, 09 Feb 2010 11:32:26 -0800
>> Yinghai Lu <yinghai@kernel.org> wrote:
>>
>>> +u64 __init find_early_area(u64 ei_start, u64 ei_last, u64 start, u64 end,
>>> + u64 size, u64 align)
>>> +{
>>> + u64 addr, last;
>>> +
>>> + addr = round_up(ei_start, align);
>>
>> Can we use include/linux/log2.h:roundup_pow_of_two() in this patchset?
>
> no, that is not what we want.
>
>
> /**
> * roundup_pow_of_two - round the given value up to nearest power of two
> * @n - parameter
> *

Hah. Naming can be a real headache with small, common operations.

At the same time, round_up() versus roundup() is a source of some
serious confusion. roundup_bin() might be a better name... I don't know.

-hpa


\
 
 \ /
  Last update: 2010-02-09 22:49    [from the cache]
©2003-2011 Jasper Spaans