lkml.org 
[lkml]   [2010]   [Feb]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 25/35] move round_up/down to kernel.h
On Sat, 13 Feb 2010 11:52:30 -0800 "H. Peter Anvin" <hpa@zytor.com> wrote:

> On 02/13/2010 10:49 AM, Joe Perches wrote:
> >
> > Having both roundup and round_up in kernel.h is a
> > near guarantee for a future incorrect use.
> >
> > Can't you use a different name for this?
> >
>
> Welcome to last week's discussion.

Which seems to have been basically ignored.

> Both of these names already exist -- yes, a rename is probably in order
> but it should be a separate patchset.

More than a rename is certainly in order.

As Joe says, if we just chuck these things into kernel.h(!) as-is,
people will start using them and the muck gets deeper.

And it's not clear who will be shovelling that muck, and when. We
haven't even worked out what needs to be done.




\
 
 \ /
  Last update: 2010-02-13 21:15    [W:0.075 / U:0.388 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site