lkml.org 
[lkml]   [2010]   [Feb]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH 1/9] bitops: rename for_each_bit to for_each_set_bit
From
Date
On Tue, 2010-02-02 at 00:10 +0900, Akinobu Mita wrote:
> Rename for_each_bit to for_each_set_bit in the kernel source tree.

I preferred the for_each_bit because it gives some
naming consistency.

These look for set bits:

find_first_bit
find_next_bit
find_last_bit

These look for unset bits:

find_first_zero_bit
find_next_zero_bit

I think there should be 3 macros named:
for_each_bit
for_each_zero_bit
for_every_bit

and maybe there's a use for:
find_last_zero_bit

I think the macro definition should be located
near these other functions in bitops.h and not
placed somewhat randomly near the top of the file.




\
 
 \ /
  Last update: 2010-02-01 18:27    [W:0.120 / U:0.656 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site