[lkml]   [2010]   [Dec]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: [PATCH] input: mt: Add an envelope tool type
    On 12/08/2010 10:52 AM, Henrik Rydberg wrote:
    >> As you noted, what we are really interested here is a bounding
    >> rectangle. I think Ping has said that Wacom could provide something that
    >> is similar to a real convex hull, and mixing the two concepts together
    >> could cause another ambiguity like BTN_TOOL_DOUBLETAP :).
    > True, we should work towards avoiding such ambiguities.
    >> I suggest merely renaming this to MT_TOOL_RECT to avoid confusion.

    This is really the main point I wanted to make, even though it was
    hidden among other things :). Do you have thoughts here?

    >> 2. We could provide for multiple simultaneous rects by using the value
    >> of the MT_TOOL_RECT property. The first rect would have value 0, the
    >> second would have value 1, etc. I don't know if this will ever be used
    >> since most devices will have real MT soon enough, but it wouldn't hurt
    >> to define this.
    > I do think this is an unnecessary complication.

    It's not really any complication. I think we should define what the
    valid values are for MT_TOOL_{RECT,ENVELOPE} even if only one envelope
    is supported. Thus, I don't see why we shouldn't allow for multiple
    values for multiple rects.

    Hardware manufacturers always seem to surprise us with what they come up
    with too :).

    -- Chase

     \ /
      Last update: 2010-12-08 20:13    [W:0.054 / U:7.896 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site