[lkml]   [2010]   [Dec]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 4/9] x86, NMI: Remove DIE_NMI_IPI and add priorties to handlers
On Tue, Nov 30, 2010 at 05:27:25PM -0500, Don Zickus wrote:
> When re-ordering how the NMI handles its callbacks, a conversation started
> asking what DIE_NMI_IPI meant. No one could answer it.

It should have came from commit

| commit c4b2bffee2a4115fed2825530f2b906ee2f17bd7
| Author: Andi Kleen <>
| Date: Fri Jan 23 18:46:40 2004 -0800
| [PATCH] x86-64 merge
| Mainly lots of bug fixes and a few minor features. One change is that
| it uses drivers/Kconfig now like i386. This requires a few minor changes in
| outside Kconfig files which I am sending separately.

Andi do you remember what the initial idea was? Didn't find any user of it
even in this old commit. Just curious.

> Noticing that is was wasteful to call the die_chain a second time with just
> another argument, DIE_NMI_IPI, it was decided to nuke it and add priorities
> to the die_chain handlers to maintain existing behaviour.
> This patch replaces DIE_NMI_IPI with the appropriate option, mostly DIE_NMI.
> Then it adds priorities to those handlers, using a globally defined set of
> priorities for NMI.
> The thought is eventually we will just switch the nmi handlers from the
> die_chain to something more nmi specific.
> Signed-off-by: Don Zickus <>
> ---

Don, maybe switching to say new chains like chain_perf and friends would be
more readable/clean? I'm not against this patch by any means, but just a thought ;)

Ie I thought like

if (!(reason & 0xc0)) {
if (notify_perf() == NOTIFY_STOP)
if (notify_die() == NOTIFY_STOP)
Or there is something obvious I'm missing?

Again, just a thought.


 \ /
  Last update: 2010-12-01 19:43    [from the cache]
©2003-2014 Jasper Spaans. hosted at Digital Ocean