[lkml]   [2010]   [Nov]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [ath9k-devel] [PATCH wireless-next] ath: Rename ath_print to ath_debug
On Mon, 2010-11-29 at 23:41 +0100, Felix Fietkau wrote:
> On 2010-11-29 7:07 AM, Peter Stuge wrote:
> > Luis R. Rodriguez wrote:
> >> On Sun, Nov 28, 2010 at 3:53 PM, Joe Perches <> wrote:
> >> > Make the function name match the function purpose.
> >> > ath_debug is a debug only facility.
> >> > ath_print seems too generic a name for a debug only use.
> >> Nack, I don't see the point.
> >
> > The point is to improve readability. I like the patch.
> And how exactly does this improve readability? Don't get me wrong, I
> generally like to see more cleanups merged to the ath/ath9k drivers
> (they do need it, after all).

It's considered polite to cc the patch author.

print is generic, debug is specific.
This function has a specific use for debugging
not a generic use all for logging.

If it was ath_print(level, etc) with KERN_<level>
passed as the first argument that'd be similar
to other kernel calls. As is, it's not.

> But in my opinion, simple renaming churn like this does nothing but
> annoy people who want to get other work done at the same time.

This sort of thing can be done when other changes have
just been merged to minimize conflicts.

> Consider the large number of lines touched (and the potential merge
> conflicts with other code because of that), relative to the microscopic
> aesthetic gain (if any).
> Instead I'd like to see more cleanups that go beyond trivial function
> renames.

I gauge my willingness to spend time on subsystems on
the maintainers willingness to merge things that improve
readability and correctness.

cheers, Joe

 \ /
  Last update: 2010-11-30 02:41    [W:0.065 / U:5.120 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site