[lkml]   [2010]   [Nov]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [ath9k-devel] [PATCH wireless-next] ath: Rename ath_print to ath_debug
On Mon, Nov 29, 2010 at 2:41 PM, Felix Fietkau <> wrote:
> On 2010-11-29 7:07 AM, Peter Stuge wrote:
>> Luis R. Rodriguez wrote:
>>> On Sun, Nov 28, 2010 at 3:53 PM, Joe Perches <> wrote:
>>> > Make the function name match the function purpose.
>>> > ath_debug is a debug only facility.
>>> > ath_print seems too generic a name for a debug only use.
>>> Nack, I don't see the point.
>> The point is to improve readability. I like the patch.
> And how exactly does this improve readability? Don't get me wrong, I
> generally like to see more cleanups merged to the ath/ath9k drivers
> (they do need it, after all).
> But in my opinion, simple renaming churn like this does nothing but
> annoy people who want to get other work done at the same time.
> Consider the large number of lines touched (and the potential merge
> conflicts with other code because of that), relative to the microscopic
> aesthetic gain (if any).
> Instead I'd like to see more cleanups that go beyond trivial function
> renames.

Thanks for putting it so clearly. Agreed.


 \ /
  Last update: 2010-11-29 23:45    [W:0.039 / U:6.380 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site