lkml.org 
[lkml]   [2010]   [Nov]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: i915: display doesn't get on back after returning from standby in 2.6.27-rc*
    On Thu, Nov 25, 2010 at 11:31:04AM -0800, Keith Packard wrote:
    > On Thu, 25 Nov 2010 11:10:58 -0500, Nick Bowler <nbowler@elliptictech.com> wrote:
    > > On 2010-11-25 16:58 +0100, Michal Hocko wrote:
    > > > [Let's add Rafael for regression tracking]
    > > >
    > > > On Tue 23-11-10 13:32:34, Michal Hocko wrote:
    > > > > Hi,
    > > > > since early 2.6.37 (I haven't bisected when exactly) my screen doesn't
    > > > > get on after it got into standby mode. I have to either change to a
    > > > > text console and back (if it gets to standby by the screen saver) or
    > > > > close the lid on my laptop if I try:
    > > > > xset dpms force standby
    > > [...]
    > > > > Is this a known issue?
    > >
    > > I suspect that all of the following are the same issue:
    > >
    > > https://bugzilla.kernel.org/show_bug.cgi?id=23122
    > > https://bugzilla.kernel.org/show_bug.cgi?id=23472
    > > https://bugs.freedesktop.org/show_bug.cgi?id=31803
    >
    > I've provided a couple of fixes that might be relevant here -- neither
    > kernel nor user mode were setting the tracked DPMS state of the outputs
    > to ON when doing mode setting, which caused all kinds of comedy. These
    > should fix 23472 and 31803. I'm not entirely sure what's up with 23122,
    > but it's possible that it's the same issue.
    >

    Where are the patches? I pulled drm-next but I don't see them.

    regards,
    dan carpenter


    \
     
     \ /
      Last update: 2010-11-26 09:49    [W:0.031 / U:90.584 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site