lkml.org 
[lkml]   [2010]   [Oct]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 3/3] fs: move i_hash out from under inode_lock
> @@ -925,8 +934,8 @@ static struct inode *get_new_inode(struct super_block *sb,
> inode->i_state = I_NEW;
> spin_unlock(&inode->i_lock);
> hlist_add_head(&inode->i_hash, head);
> + spin_unlock(&inode_hash_lock);
> inode_sb_list_add(inode);
> - spin_unlock(&inode_lock);

Al said he wanted to have the sb lock nest inside the hash lock for now
I think. Doubt it matters much, but it keeps the behaviour that we
can't look up an inode which is not added to the per-sb list yet.

After that a better patch description might be:

"rename inode_lock to inode_hash_lock"

as the inode_lock coverage after the previous patches should be 100%
identical to the new hash lock.


\
 
 \ /
  Last update: 2010-10-28 16:27    [W:0.294 / U:0.464 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site