[lkml]   [2010]   [Oct]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: [patch] x86: allow ZONE_DMA to be configurable

    * H. Peter Anvin <> wrote:

    > On 10/14/2010 09:00 AM, Pekka Enberg wrote:
    > >> CONFIG_EMBEDDED *is* "I am a user who (think I) know what I'm
    > >> doing". That is *what it is* and *all it is*.
    > >
    > > Yup. The naming is quite unfortunate, though. Can we change it to
    > > something else?
    > Funny, this seems to come up repeatedly ;)

    I'd suggest to rename CONFIG_EMBEDDED=y to CONFIG_EXPERT=y, but i'd also
    suggest to rename all sub-config-options that depend on CONFIG_EXPERT to
    have a CONFIG_EXPERT_ prefix.

    So we'd have:



    That way all the enabled 'expert options' become easily visible in the
    .config file and they advertise themselves properly - it's also easily
    greppable. In the source code it also becomes self-documenting, it's
    obvious when a dependency is 'rare' or 'special' - it has a
    CONFIG_EXPERT_ prefix.

    Something for the KS i guess.



     \ /
      Last update: 2010-10-14 20:37    [W:0.022 / U:2.696 seconds]
    ©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site