lkml.org 
[lkml]   [2010]   [Jan]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 9/12] ACPI / PM: Introduce acpi_pm_wakeup_power()
On Sun, 27 Dec 2009 21:06:26 +0100
"Rafael J. Wysocki" <rjw@sisk.pl> wrote:
> /**
> + * acpi_pm_wakeup_power - Enable/disable device wake-up power.
> + * @dev: ACPI device to handle.
> + * @enable: Whether to enable or disable the wake-up power of the
> device.
> + */
> +int acpi_pm_wakeup_power(struct acpi_device *dev, bool enable)
> +{

I know we've got these all over now, but functions that just take a
bool are generally hard to read when you just look at the call site.
If it was called "acpi_pm_set_wakeup_power" and then took an on/off
enum it would be really easy to see, from the callsite, what was going
on.

It's a fairly minor complaint, but it's something that's always bugged
me about the PCI PM code in particular.

--
Jesse Barnes, Intel Open Source Technology Center


\
 
 \ /
  Last update: 2010-01-06 23:03    [from the cache]
©2003-2011 Jasper Spaans