lkml.org 
[lkml]   [2010]   [Jan]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: i915: gpu wedged [was: mmotm 2010-01-15-15-34 uploaded]
On Sat, 23 Jan 2010 13:56:05 +0100
Jiri Slaby <jirislaby@gmail.com> wrote:

> On 01/16/2010 12:34 AM, akpm@linux-foundation.org wrote:
> > The mm-of-the-moment snapshot 2010-01-15-15-34 has been uploaded to
>
> So I've decided to switch to KMS on this kernel with
> 00:02.0 VGA compatible controller [0300]: Intel Corporation 82G33/G31
> Express Integrated Graphics Controller [8086:29c2] (rev 02) (prog-if 00
> [VGA controller])
> Subsystem: Intel Corporation 82G33/G31 Express Integrated
> Graphics Controller [8086:29c2]
> Flags: bus master, fast devsel, latency 0, IRQ 26
> Memory at ffa80000 (32-bit, non-prefetchable) [size=512K]
> I/O ports at ec00 [size=8]
> Memory at d0000000 (32-bit, prefetchable) [size=256M]
> Memory at ff900000 (32-bit, non-prefetchable) [size=1M]
> Expansion ROM at <unassigned> [disabled]
> Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
> Capabilities: [d0] Power Management version 2
> Kernel driver in use: i915
>
>
> with this X driver:
> (II) Module intel: vendor="X.Org Foundation"
> compiled for 1.7.4, module version = 2.10.0
> Module class: X.Org Video Driver
> ABI class: X.Org Video Driver, version 6.0
>
>
> on X.Org X Server 1.7.4 and after some time I get:
> (WW) intel(0): i830_uxa_prepare_access: gtt bo map failed: Input/output
> error
> (EE) intel(0): Failed to submit batch buffer, expect rendering
> corruption or even a frozen display: Input/output er
> ror.
> (WW) intel(0): i830_uxa_pixmap_swap_bo_with_image: bo map failed
> (WW) intel(0): i830_uxa_prepare_access: gtt bo map failed: Input/output
> error
> (WW) intel(0): i830_uxa_prepare_access: gtt bo map failed: Input/output
> error
> (WW) intel(0): i830_uxa_prepare_access: gtt bo map failed: Input/output
> error
> (EE) intel(0): Failed to submit batch buffer, expect rendering
> corruption or even a frozen display: Input/output er
> ror.
> (EE) intel(0): Failed to submit batch buffer, expect rendering
> corruption or even a frozen display: Input/output er
>
>
> and kernel says:
> [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
> render error detected, EIR: 0x00000000
> [drm:i915_do_wait_request] *ERROR* i915_do_wait_request returns -5
> (awaiting 153151 at 153150)
> [drm:i915_gem_execbuffer] *ERROR* i915_gem_do_execbuffer returns -5
>
>
> >From <debugfs>/dri/0/i915_wedged, the GPU is wedged.
>

umph. There isn't much I can do about that, really. Apart from
fervently hoping that this known regression doesn't turn up in
2.6.34-rc1.



\
 
 \ /
  Last update: 2010-01-27 23:27    [from the cache]
©2003-2011 Jasper Spaans