lkml.org 
[lkml]   [2010]   [Jan]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH] ata: Disable NCQ for Crucial M225 brand SSDs
From
On Tue, Jan 26, 2010 at 7:21 PM, Vishal Rao <vishalrao@gmail.com> wrote:
> 2010/1/27 David Rees <drees76@gmail.com>:
>> Have there been any other reports of NCQ issues with similar Crucial
>> drives or Indilinx?
>
> I haven't personally seen reports of NCQ specific issues. I have seen
> people (online) reporting "issues" with Linux distro installations
> hanging/freezing etc. and some prior attempts at SMART fixes which
> I also initially tried but did not work for me.
>
> I have tried to "publicise" this issue (forum, blog, mailing list posts)
> in the hope more users may search and identify the correct issue
> so that it may be better verified.
>
> Unfortunately, the Crucial ID string is not model-agnostic (if thats
> the right term)... meaning the patch has 3 lines to ID the 3 current
> models that I know of including my own 128 GB model.
>
> Not sure if there's a better, more generic way to match a whole group
> of SSDs (same model family or various vendors) which trigger NCQ errors?

How to define a group gets... Messy. Just as a data point, my own
Barefoot-based SSD, an OCZ Vertex, has no NCQ-related problems
whatsoever, so far as I know. Its currently hooked to a Zotac ION
board, which has ahci-driven sata controllers of some sort, was
previously in a Dell Studio Hybrid, where it also worked just fine.

--
Jarod Wilson
jarod@wilsonet.com


\
 
 \ /
  Last update: 2010-01-27 16:41    [W:0.052 / U:3.680 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site