lkml.org 
[lkml]   [2010]   [Jan]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: High pitch noise when ACPI processor module is loaded.
On Mon, 25 Jan 2010, Justin Piszcz wrote:

> Hi,
>
> I think something else may be wrong?
>
> I switched my kernel config to 100 HZ and the problem persists.
>
> So the question remains, is it possible to utilize turbo boost (in Linux)
> without the high pitch noise from the ACPI processor module?
>
> Again, when the module is not loaded, no matter what HZ, there is no high
> pitch noise.
>
> Justin.
>
>

Without ACPI processor module loaded, turbo boost never takes effect:

(turbostat)

CPU GHz TSC %c0 %c1 %c3 %c6 %pc3 %pc6 %pc7
0 2.93 2.93 1.41 98.59 0.00 0.00 0.00 0.00 0.00
1 2.93 2.93 100.00 0.00 0.00 0.00 0.00 0.00 0.00
2 2.93 2.93 1.51 98.49 0.00 0.00 0.00 0.00 0.00
3 2.93 2.93 0.97 99.03 0.00 0.00 0.00 0.00 0.00
4 2.93 2.93 0.90 99.10 0.00 0.00 0.00 0.00 0.00
5 2.93 2.93 0.34 99.66 0.00 0.00 0.00 0.00 0.00
6 2.93 2.93 0.40 99.60 0.00 0.00 0.00 0.00 0.00
7 2.93 2.93 3.07 96.93 0.00 0.00 0.00 0.00 0.00

With the module loaded, it works but there is a high pitch noise, again,
only under Linux, when the same benchmark (bzip2 a file) is run under windows
there is no high pitch noise:

CPU GHz TSC %c0 %c1 %c3 %c6 %pc3 %pc6 %pc7
0 3.30 2.93 0.44 0.82 25.29 73.44 0.00 0.00 0.00
1 3.33 2.93 0.24 1.02 25.29 73.44 0.00 0.00 0.00
2 3.43 2.93 1.84 5.41 48.65 44.10 0.00 0.00 0.00
3 3.41 2.93 0.49 6.76 48.65 44.10 0.00 0.00 0.00
4 3.58 2.93 99.44 0.56 0.00 0.00 0.00 0.00 0.00
5 3.43 2.93 0.03 99.97 0.00 0.00 0.00 0.00 0.00
6 3.09 2.93 0.14 0.23 89.74 9.89 0.00 0.00 0.00
7 2.13 2.93 0.01 0.36 89.74 9.89 0.00 0.00 0.00


Justin.




\
 
 \ /
  Last update: 2010-01-25 10:59    [W:0.066 / U:0.788 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site