[lkml]   [2010]   [Jan]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [tip:x86/mce] x86, mce: Rename cpu_specific_poll to mce_cpu_specific_poll

* tip-bot for H. Peter Anvin <> wrote:

> Commit-ID: f91c4d2649531cc36e10c6bc0f92d0f99116b209
> Gitweb:
> Author: H. Peter Anvin <>
> AuthorDate: Thu, 21 Jan 2010 18:31:54 -0800
> Committer: H. Peter Anvin <>
> CommitDate: Thu, 21 Jan 2010 18:31:54 -0800
> x86, mce: Rename cpu_specific_poll to mce_cpu_specific_poll
> cpu_specific_poll is a global variable, and it should have a global
> namespace name. Since it is MCE-specific (it takes a struct mce *),
> rename it mce_cpu_specific_poll.
> Signed-off-by: H. Peter Anvin <>
> Cc: Andi Kleen <>
> LKML-Reference: <>

FYI, this commit triggered a -tip test failure:

arch/x86/kernel/cpu/mcheck/mce-xeon75xx.c: In function 'xeon75xx_mce_init':
arch/x86/kernel/cpu/mcheck/mce-xeon75xx.c:340: error: implicit declaration of function 'pci_match_id'

I'm excluding it from tip:master.

But the bigger problem with this commit is structure of it - or the lack

It just blindly goes into the direction the MCE code has been going for some
time, minimally enabling the hardware, ignoring both the new EDAC design and
the new performance monitoring related design i outlined some time ago.

Newly introduced MCE code in the x86 tree should be integrated much better
into existing higher level facilities, not just limp along ignoring life
outside of its little box. This will have to be addressed before we can
reintroduce this commit, even if this trivial build failure is addressed.

I've Cc:-ed a few more interested parties.



 \ /
  Last update: 2010-01-23 06:19    [W:0.056 / U:5.244 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site