lkml.org 
[lkml]   [2010]   [Jan]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    Patch in this message
    /
    Date
    From
    SubjectRe: sata_nv times out for BD-ROM iHOS104-08
    Hello,

    On 01/18/2010 12:28 AM, Ozan Çağlayan wrote:
    > [ 9.769407] ata1: nv_mode_filter: 0x739f&0x739f->0x739f, BIOS=0x7000 (0xc000c700) ACPI=0x701f (60:600:0x13)
    > [ 9.775326] ata1.00: configured for UDMA/33
    > [ 9.775408] ata1.00: TEST_UNIT_READY failed (err_mask=0x2)

    Hmmm... err_mask=0x2 is HSM error. Strange. Does the attached patch
    make any difference?

    Thanks.

    --
    tejun
    diff --git a/drivers/ata/libata-eh.c b/drivers/ata/libata-eh.c
    index 0ea97c9..df261ac 100644
    --- a/drivers/ata/libata-eh.c
    +++ b/drivers/ata/libata-eh.c
    @@ -3530,7 +3530,7 @@ int ata_eh_recover(struct ata_port *ap, ata_prereset_fn_t prereset,
    /* If reset has been issued, clear UA to avoid
    * disrupting the current users of the device.
    */
    - if (ehc->i.flags & ATA_EHI_DID_RESET) {
    + /*if (ehc->i.flags & ATA_EHI_DID_RESET) {
    ata_for_each_dev(dev, link, ALL) {
    if (dev->class != ATA_DEV_ATAPI)
    continue;
    @@ -3538,7 +3538,7 @@ int ata_eh_recover(struct ata_port *ap, ata_prereset_fn_t prereset,
    if (rc)
    goto dev_fail;
    }
    - }
    + }*/

    /* retry flush if necessary */
    ata_for_each_dev(dev, link, ALL) {
    \
     
     \ /
      Last update: 2010-01-19 10:07    [W:0.039 / U:29.536 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site