lkml.org 
[lkml]   [2010]   [Jan]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    From
    Date
    SubjectCompat / compat-wireless / bluetooth for 2.6.33-rc4 and 2.6.32.3
    The 2.6.33-rc4 and 2.6.32.3 kernels came out a few days ago, along
    with it comes the respective 2.6.33-rc4 [1] and 2.6.32.3 [2]
    compat-wireless releases [3]. As noted previously the
    compat-wireless-2.6.33 releases now also have bluetooth backported for
    kernels >= 2.6.27.

    A few release notes:

    * compat.git - generic kernel compatibility package. This is
    currently used on bleeding edge compat-wireless and the 2.6.33
    compat-wireless releases. Other external drivers are welcomed to take
    advantage of this though.
    - gets pm-qos for kernels down to 2.6.23
    - gets the new 2.6.33 firmware_class backported for older kernels
    which allows usage of
    drivers with thew new request_firmware_nowait(). Users of this for
    802.11 right now are ar9170.
    This actually goes only compile tested, please let me know if this worked.

    * compat-wireless-2.6.32.3:
    - now goes all the way down to 2.6.23 for ath5k and ath9k, should
    be easy to test/enable others
    - gets pm-qos backport as well

    * compat-wireless-2.6.33-rc4:
    - The new debugfs_remove_recursive(), added as of 2.6.26 but used
    on 802.11 only until
    2.6.32-rc4 on both mac80211 and cfg80211 cannot be backported as
    it relies on two
    static variables on fs/debugfs/inode.c, to enable backporting
    for older kernels than
    2.6.26 we'll need to relabel CONFIG_CFG80211_DEBUGFS and
    CONFIG_MAC80211_DEBUGFS
    and disable them for older kernels.

    Due to the new multiqueue patch we only support kernels >= 2.6.27 on
    bleeding edge compat-wireless. This patch is due to go into stable
    down to 2.6.32 so both next releases 2.6.32.4 and 2.6.32-rc5 are
    expected to have this and as such will have backporting disabled for
    older kernels as well until we figure out how to properly backport
    this.

    The compat-wireless 2.6.32.3 release causes this harmless warning on
    older kernels < 2.6.24, it can safely be ingored, I see no way of
    avoiding it.

    CC [M] /home/mcgrof/devel/compat-wireless-2.6/net/rfkill/input.o
    In file included from
    /home/mcgrof/devel/compat-wireless-2.6/net/rfkill/input.c:16:
    include/linux/input.h:933:1: warning: "BIT" redefined
    In file included from include/asm-i386/cpufeature.h:11,
    from include/asm/cpufeature.h:10,
    from include/asm/alternative.h:43,
    from include/asm/atomic.h:4,
    from
    /home/mcgrof/devel/compat-wireless-2.6/include/net/compat-2.6.24.h:11,
    from
    /home/mcgrof/devel/compat-wireless-2.6/include/net/compat.h:15,
    from <command-line>:0:

    Luis

    [1] http://www.orbit-lab.org/kernel/compat-wireless-2.6-stable/v2.6.33/compat-wireless-2.6.33-rc4.tar.bz2
    [2] http://www.orbit-lab.org/kernel/compat-wireless-2.6-stable/v2.6.32/compat-wireless-2.6.32.3.tar.bz2
    [3] http://wireless.kernel.org/en/users/Download/stable


    \
     
     \ /
      Last update: 2010-01-14 08:25    [W:0.021 / U:122.740 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site