[lkml]   [2010]   [Jan]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH] m68knommu: change definitions of __pa() and __va()

On Tue, 12 Jan 2010, Greg Ungerer wrote:
> +#else
> +#define page_to_phys(page) ((page - mem_map) << PAGE_SHIFT)
> +#define page_to_bus(page) ((page - mem_map) << PAGE_SHIFT)
> +#endif

Ok, so the old ones were total crap too, but when moving things around,
don't just copy the crap like this.

Look at those two #define's for five seconds, and ask yourself what is
wrong with them. Those macros are not good.


 \ /
  Last update: 2010-01-12 01:57    [W:0.031 / U:7.160 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site