lkml.org 
[lkml]   [2009]   [Sep]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v4 0/4] Use macros rather than hardcoding section names
On Sun, Sep 20, 2009 at 06:14:11PM -0400, Tim Abbott wrote:
> This patch series cleans up the kernel's explicit references to
> .data.page_aligned, .bss.page_aligned, and .data.init_task in C and
> assembly code to instead use the standard macros for that purpose.
>
> Version 4 differs from version 3 in two ways:
> - It is rebased on top of current kbuild-next/master
> - __LINKER_SCRIPT__ was renamed to LINKER_SCRIPT
>
> Version 3 differs from version 2 in two ways:
> - The .data.init_task patch also updates the score architecture
> - The powerpc __page_aligned_data patch was removed (since Benjamin
> Herrenschmidt said he was taking it).
>
> Version 2 differed from version 1 in that it added the kbuild patch,
> fixing breakage in the x86 linker script caused indirectly by
> including linux/linkage.h in x86's asm/cache.h.
>
> This cleanup is in preparation for being able to change the names of
> the .data.page_aligned and .bss.page_aligned sections to be
> compatible with -ffunction-sections -fdata-sections (a prerequisite
> for Ksplice).
>
> Joe Perches (1):
> Use new __init_task_data macro in arch init_task.c files.
>
> Tim Abbott (3):
> kbuild: Don't define ALIGN and ENTRY when preprocessing linker
> scripts.
> Use macros for .bss.page_aligned section.
> Use macros for .data.page_aligned section.

Thanks - applied all 4.

Sam


\
 
 \ /
  Last update: 2009-09-21 06:27    [from the cache]
©2003-2011 Jasper Spaans