[lkml]   [2009]   [Sep]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: 2.6.31-rc5 regression: hd don't show up

    Tim Blechmann wrote:
    > with this patch, i could reproduce it again on the first boot. bootlog
    > attached.

    Thanks a lot for testing. The offending commit is 816ab897.

    commit 816ab89782ac139a8b65147cca990822bb7e8675
    Author: Tejun Heo <>
    Date: Wed Oct 22 00:31:34 2008 +0900

    libata: set device class to NONE if phys_offline

    Reset methods don't have access to phys link status for slave links
    and may incorrectly indicate device presence causing unnecessary probe
    failures for unoccupied links. This patch clears device class to NONE
    during post-reset processing if phys link is offline.

    As on/offlineness semantics is strictly defined and used in multiple
    places by the core layer, this won't change behavior for drivers which
    don't use slave links.

    Signed-off-by: Tejun Heo <>
    Signed-off-by: Jeff Garzik <>

    The problem is that I don't really remember why I added this one back
    then. This is incorrect because the condition should be dealt with
    later in the reset logic. That didn't work quite as expected and I
    ended up adding the above to work around that and it turned out wrong.
    I'll dig deeper and find out what was the problem back then.



     \ /
      Last update: 2009-09-16 04:23    [W:0.022 / U:2.812 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site